Working in Maya

From Sirikata Wiki
Revision as of 23:50, 9 May 2011 by Ewencp (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This article goes over the basics of working in Maya. Not all of the following steps are essential (you won't need to bother with Soften normals if you are making a box, for example) but certain sections, such as Object Naming, are imperative to the Sirikata pipeline. It is suggested that you read the full article before skipping any steps so that you don't miss something important on accident.


Harden/Soften Normals

Maya default assumes that all of your edges are hard-edged surfaces when you are modeling. In some instances you may want to soften certain edges or make certain edges hard. Select the edges to soften or harden via edge mode, then go to Normals > Soften Edge (or Harden Edge) in the polygon menu.


Creating Multiple UV Sets

Go to Window > UV Texture Editor > Polygons > Copy UVs to UV Set. Alternatively you can create an empty UV set, especially if you need to change the UVs or how they are laid out.

NOTE: When naming the new UV set, use map1, map2, map3 for your UV set names.


Assigning Multiple Materials

In order to help speed up the process of working within 3DS Max, Maya users should utilize assigning different materials (always phong) to faces that use a different material, even if they are part of the final object. A case example would be the Glass of a window within its frame. The frame has a different material from the glass.

To do this in Maya, simply select the faces that will be the different material and either choose Assign New Material > Phong (or Assign Existing Material if you have already created a material).


Object Naming

It is important to maintain naming for the purposes of redundancy and knowing what is what. Within Maya open Window > Outliner and simply double click on the mesh and rename it accordingly.

NOTE: Naming is important as the end exported FOLDER to Ogre must be named the mesh name, in this case /tree_ash01/. (Disregard the file name in the screenshot; it should be tree_ash01)


Set Pivot Points

There are several options depending on the workflow of your scene to set the pivot point. Primary Example: A single object for import into Sirikata

Make sure to move the object to the center of the grid. You can do this by selecting the object, hitting W for translation, and holding down 'X' to force the object to snap to the grid, then moving it to the center of the grid.

This centers the object to the world space. In this example the tree is standing on the grid, this way when moving around in Sirikata the tree can be placed using its pivot on the bottom, where it will be across Terrain. With other models you will want to center the pivot first in the model, then snap the model to the grid in Maya's World Space.

To Center the pivot of the model, go to Modify > Center Pivot.

After you are completely finished with the mesh, you should delete the History to clear out any metadata that we don't need to save. Go to Edit > Delete All by Type > History.


Freeze Transformations

Next is it important to freeze the transformations on the mesh. Do this when you are utterly completed with the mesh, and AFTER you have deleted the History. Go to Modify > Freeze Transformations.


Export Using COLLADA

You probably want to use the OpenCOLLADA plugin for Maya to export in COLLADA format.

Make sure the object or objects that are finished and ready for export are selected, and then go to File > Export Selection… A dialogue box will appear. Make sure only the following checkboxes are checked:

  • Default file extensions (.dae)
  • Polygon Meshes
  • Normals
  • Texture Coordinates
  • Export References
  • YFov