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Introduction

This document is designed for users to introduce themselves to the 3D production pipeline of
Sirikata, a BSD licensed open source platform for games and virtual worlds. The various articles in this
document will teach you how to prepare and import your 3D assets so that they may be viewed correctly
in the engine. While Sirikata was designed so that even casual users may access virtual worlds, to create
content for it is a more challenging task that requires at least an intermediate knowledge of such
programs as Photoshop and 3D Studio Max 9. You should feel comfortable using the interfaces within
these programs, including such activities as installing plugins, importing/exporting files, etc.

The 3ds Max Exporter for Sirikata is designed to take the object and shader set up from 3D Studio
Max directly into Sirikata and maintain the Material settings and properties. Users of other 3D packages
such as Maya, XSI, etc, can model, UV Map (up to 3 UV sets), export the mesh using Collada, and import
the mesh into 3ds Max. Assuming the user has their mesh in 3ds Max, we have provided this workflow
document to guide users in the creation of Materials in 3ds Max. Users can then take their 3D meshes
specifically optimized for Sirikata, and export them using the provided plugin.



Basic Requirements

The evolving content production pipeline currently uses these programs and plugins in order for you to
produce content for the engine.

Adobe Photoshop CS or later

3D Studio Max 9 32-bit

Latest version of Sirikata

NVIDIA dds plug-in is for Photoshop to convert all texture maps into the .dds format.

COLLADA for Maya - Currently most of our art team works in Maya for modeling and UV
mapping, using COLLADA to export the mesh for 3ds Max.

COLLADA for 3ds Max 9 - Used to import COLLADA files into 3ds Max.

Ogre Exporter for 3ds Max 32 bit is a custom built exporter for the Sirikata engine by our team.

Optional Tools:

Crazybump, a texture generator that uses a diffuse texture to create normal and specular maps.
NVidia Texture Tools 2, a standalone version of the NVidia plugin for Photoshop that is GPU-
accelerated.

MysticThumbs allows you to see .DDS files as thumbnails in Windows Explorer. It has both 32 bit
and 64 bit versions, unlike NVidia’s own thumbnail extension.

Example Files

Along side this .PDF file, you’ve probably noticed a folder titled “example_files.” Inside this folder you will
find subfolders, each with specific files for each program. These folders have been included along with
this document so that if you find yourself confused at any point, you can refer to our own files in order to
try and figure out where you may have made a mistake. The guide was made using these files, so for
those of you who are importing into Sirikata for the first time, it may be a good idea to follow along with
the guide and use the example files.


http://sirikata.com/builds/�
http://developer.nvidia.com/object/photoshop_dds_plugins.html�
http://sourceforge.net/projects/colladamaya/files/COLLADAMaya%201.4.1%20plug-ins/ColladaMaya_FREE_3.05B.exe/download�
http://sourceforge.net/projects/colladamaya/files/COLLADAMaya%201.4.1%20plug-ins/ColladaMax_FREE_3.05C.exe/download�
http://www.sirikata.com/res/dev_preview/SirikataSceneExporter.zip�
http://www.crazybump.com/�
http://developer.nvidia.com/object/texture_tools.html�
http://mysticcoder.net/mysticthumbs/�

Plugin Installation

Sirikata requires a number of plugins in order for your content to be imported into the engine. Instead of
supporting multitudes of file types, these plugins allow for us to ensure that there is a standard way of
creating content for Sirikata so that everything is uniform, making it easier to pinpoint problems (should
there be any).

Installing the NVidia .dds file format plugin for Photoshop 32-bit

1. Go the NVidia plugin page and download the latest version.

Available Downloads

Curre n (8.23.1101)
& Download Legacy Version (7.83.0628)

& Nowrnload Current -
LUownioad U MErS

(=]

Once you have downloaded the plugin, follow the on screen instructions for installation.

3. You will be asked to choose a folder for installation. It will use the default Adobe directory. If
you have installed Photoshop anywhere else, please change it accordingly.

4. Finish the installation and open Photoshop. Go to File > New and create a new, blank document.

5. Goto File > Save As... and choose D3D/DDS (*.DDS). If you see this option, that means the

installation of the plugin was successful.
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File name: glass_skylight_bubble01 COL v
Format: | D3D/DDS (".DDS) -|



http://developer.nvidia.com/object/photoshop_dds_plugins.html�

Troubleshooting for NVidia .dds plugin

1. The plugin does not work with 64-bit versions of Photoshop. If you have a 64-bit version of
Windows, you will need to install the plugin for the 32-bit version of Photoshop, installed by
default in C:\Program Files (x86)\Adobe.

2. If you cannot choose .DDS from the Save As... menu, the plugin may not have been installed
properly. Go to your Photoshop folder, normally located at C:\Program Files\Adobe, or
C:\Program Files (x86)\Adobe for 64-bit users, and open your Photoshop directory. Go to Plug-
ins and then File Formats. Inside this director you should see a list of files with the extension
.8BI. You should see the file dds.8BI. If not, run the installer again and make sure you install to
the right directory (the installer wants the root directory of Photoshop, so always install to there:
C:\Program Files\Adobe\Adobe Photoshop CSX).

Installing the Ogre Exporter for 3ds Max 9 32-bit

1. Download the Ogre Exporter for 3ds Max 32 bit from the Sirikata wiki.

2. Open SirikataSceneExport.zip and open the folder “OgreExporter.”

3. Navigate to your 3ds Max 9 folder, located at C:\Program Files\Autodesk\3ds Max 9 for 64-bit
and C:\Program Files\Autodesk\3ds Max 9 for 32-bit computers.

4. Open the 3ds Max 9 folder.

5. Go back to SirikataSceneExport.zip and copy the contents of “OgreExporter” into the main 3ds

Max 9 folder.
=[=] == B sirikataSceneExporterzip - WinRAR (only 16 days left to to buy a license) — [E= IS
@7«\ "H File Commands Tools Favorites Options Help
B~ _ o >
i |§-ME@§Q@' W 4%
M, = . Add  ExtractTo  Test View Delete Find Wizard Info VirusScan Comment  SF»
Fsromte Tinks lame Date medified Type : B
IF| Documents 1 3ds Max9 7/15/2009 4:02PM  File Folder E B sirikataSceneExporter.zip\OgreExporter - ZIP archive, unpacked size 259,114,002 bytes
. U Autodesk DWF Viewer  6/26/2009 %15 AM  File Folder .
I Ficnees J. Backbumer 6/26/20093:23 AM  File Folder fome s miadedmdyEves jriadiike
B Music 1 FBx 6/26/20099:26 AM  File Folder ki - Eolcer
Mare » Folder
Folders v ugin_CgProgramManager.dIl 57,344 8,514 Application Exte
greGUIRenderer.dll 61,440 Application
1 Adobe = ugin_ParticleFX.dll 02,912 Application
. AGEHA Technologi b1.dli L 3 Application Ex
L Alienware ugin_CgProgramManager_d.dll 80,221 666 Application
. Apple Software UpB el erer_d. Application
1 Autodesk neManager.dil 80,224 Application
1 3ds Max9 in_ e Application
0 Autodesk DWFV in_P. § 63,287 Application
. Backbumner | er. 0 & Application
L FBX i e er. 41,66 Application
1. Bioshock 5 _Direct3D9.dll Application
1 Bonjour | neManager_d.dll Application
4 CCleaner Application
)i Cisco Application
Ju Citrix Application
L Common Files ™ | * I, | Application
] 4 items i 07, Application Extens.
E3 ™0 Selected 1 folder and 39,374,336 bytes in 25 files Total 1 folder and 39,374,336 bytes in 25 files
L == e e

6. Give Windows permission to overwrite any necessary files.

7. Start 3ds Max and open your file. When it is ready to be exported, go to OgreMax > Export
Selected 0.1.3.

8. THE OGRE EXPORTER CAUSES 3DS MAX TO CRASH ON STARTUP. READ THE
TROUBLESHOOTING SECTION FOR MORE INFORMATION.


http://www.sirikata.com/res/dev_preview/SirikataSceneExporter.zip�

Troubleshooting for Ogre Exporter

The exporter currently has a bug which our team has been unable to fix. Every time the exporter
is used, 3ds Max creates a .mnu file. The file, MaxStartUl.mnu, causes 3ds Max 9 to crash the
next time it is loaded unless you delete MaxStartUl.mnu prior to opening the program. It is
suggested that you make a shortcut to this folder and keep it on your Desktop or with your other
Sirikata files so that it is easy to access. A fix for this problem is underway and will be released
ASAP. The location of the folder varies depending on whether you are using XP or Vista.

a) Vista: C:\Users\YourAccount\AppData\Local\Autodesk\3dsmax\9 - 32bit\enu\UlI

b) XP: C:\Documents and Settings\Administrator\Local Settings\Application

If you have any other problems with the Ogre Exporter, you may have installed it wrong. Make
sure that the file OgreMaxSceneExporter.gup is in the plugins folder, found at C:\Program
Files\Autodesk\3ds Max 9\plugins. If the file is located in plugins but you are still having

1.
Data\Autodesk\3dsmax\9 - 32bit\enu\UlI
2.
problems, read on below.
3.

Even if all of the Ogre Exporter files appear to be in order, if it does not appear as it should within
3ds Max 9, try reinstalling the plugin by copying all the files over again. You may have originally
placed them in the wrong directory.

Installing COLLADA for 3ds Max 9 32-bit

1. Download COLLADA for 3ds Max 9. Under the dropdown menu COLLADAMax 1.4.1 plug-ins,
choose ColladaMax_FREE_3.05C.exe. When you open this file, it should automatically find your
3ds Max 9 file folder.

2. Follow the on screen instructions. You will be prompted to choose if you want to install the
plugin for more than one version of Max. You may install as many options as you want as long as
the plugin is installed for 3ds Max 9.

3. Open 3ds Max and go to File > Import. You should be able to choose “COLLADA (*.DAE, *.XML)”
under the file type options.

All Files

¥ COLLADAMax 1.4.1 plug-ins

¥ ColladaMax_FREE_3.05C.exe

Installing COLLADA for Maya

1. Download COLLADA for Maya . Under the
Colladalax_FREE_3.05C.exe dropdown menu COLLADAMaya 1.4.1 plug-ins,
o et choose ColladaMaya_FREE_3.05B.exe. When
i you open this file, it should automatically find
¥ COLLADAMaya 1.4.1 plug-ns your Maya folder.
2. Follow the on screen instructions. You will be
¥ 3.058 prompted to choose if you want to install the
plugin for more than one version of Max. You
ColladaMax_FREE_3.058.exe may install as many options as you want as long
. , - o S , as the plugin is installed for your version of
ColladaMax_FREE_3.05B_3dsMax2008_AMDE4_binary.zip
Maya.
ColladaMax_FREE_2.05B_3dsmax2003_AMDE4_binary.zip 3. Open Maya and go to File > Export Selected.

ColladaMax_FREE_3.058 3dsmax2009_i336_binary.zip

ColladaMaya_3J 05BU tar.gz

ColladaMaya_FREE_3.05B.exe

You should be able to choose “COLLADA” under
file type options.


http://sourceforge.net/projects/colladamaya/files/�
http://sourceforge.net/projects/colladamaya/files/�

Project Setup

Naming Conventions

It is imperative to have a basic understanding of file organizing and naming that is intuitive enough for
most content creators to readily access content for use. For the purposes of Sirikata Content development
and utilizing the import pipeline we are sharing the method we utilize for current projects in an attempt
to help guide future developers.

NOTE: If you are sharing files with a group, place the date at the end of the file name (e.x. 07_29_09)

Mesh Naming

Mesh names within various 3D programs may be named in various fashions, for example in Maya you may
rename an object "Object1" and Maya still maintains a sub meta-data called "Object1Shape". In any
regard it is recommended to artists to control their naming to help prevent future confusion or conflicts.

In the following example each mesh is named finally within 3DS Max before exporting using the Ogre
Exporter plugin. This way, the mesh name and the folder name of the exported mesh, materials, and so
forth are contained within the appropriate folder of the name of the mesh. The method of naming is as
follows:

= Material (Material Object is made out of NOT 3D/2D material - glass)
=  Type (window or win)

= Structure (skylight or skylgt)

= Structure Type (if applicable - bubble)

=  Project (if applicable; e.g., Kunst Bornholm Museum)

= Version # or Iteration

The example below is specifically the glass, and only the glass, used for the bubble type skylight of
Bornholm's Kunst museum:
glass_window_skylight_bubble_kunst01

The frame for the skylight would be named as follows:
frame_skylight_bubble_01

It may not always be necessary to include the project name as this skylight can be reused, along with its
glass component, within any project.

Texture Naming

The method for naming textures is similar to naming models. There are, however, key components that
are required to maintain consistency between the various types of texture. They are abbreviated as the
following:

= Color / Diffuse Map - COL

=  Ambient Occlusion Map - AO

= Specular Map - SPC

= Tangent Normal Map - NRM

=  Environment Reflection Map - ENV
= Glow Maps - GLO

= Bump Map - BMP

= Displacement Map — DISP



Here is an example set of textures created specifically for the skylight model mentioned before. You
would want to emulate this name convention for your own texture files.

= glass_skylight_bubble01_COL
= glass_skylight_bubble01_SPC
= glass_skylight_bubble01_AO
= glass_skylight_bubble01_NRM

While some textures are made and UV mapped to a specific model, many textures in Sirikata are tileable
and can be used on terrain or applicable models. Things such as grass, bricks, and concrete fall under the
category of tileable textures. Listed below are examples of tileable textures:

= tree_bark01_COL — (tileable bark texture)

= grass_short01_COL — (short grass, could be any color, if a specific color needs to be handled then)

= grass_shortbrown01_COL - (short brown grass, probably dead or dying grass)

= rock_cliff_kunst01_COL — (a cliff texture specifically for the Bornholm Kunst Museum project)

=  stone_path_kunst01_COL (a stone path texture specifically for the Bornholm Kunst Museum project)

A general list of top-level names for textures is as follows:

=  Tree = Bush =  Rock = Stone = Dirt

= Grass = Road = Concrete =  Roof = Tar

= Plaster = Brick = Drywall =  Wood =  Pattern
= Stucco = Blacktop = Paint =  Paneling =  Siding



Sample Folder and File Structure

/sirikata/
-The system, platform, engine and everything once it is imported.

/sirikatacontent/documentation/
-Where all documentation exists for Sirikata, Pipeline, Tutorials, etc.

/sirikatacontent/
-Primary asset storage area for use by content designers, this resides separately and is before final
import to Sirikata.

/sirikatacontent/mesh
-The top directory for models. Every model will have its own folder within the directory.

/sirikatacontent/ogreexports/
-where all exported scenes go, the folder of the export and its accompanying files (/ash_01/ash_01.scene
ash_01/materials etc) These folders within are ready to be dragged directly into Sirikata.

/sirikatacontent/textures
-Finalized Textures ready for import, and to be used during material creation within Max.

/sirikatacontent/textures/TYPE
-Type deliniates the type of texture, this is purely for ease of storage use for artists as once the export is
complete, the texture resides within its corresponding mesh folder, under materials.

/sirikatacontent/texture_ref/
-The massive folder utilized for working on textures, texture references, photos and all collage
references for each project.

/sirikatacontent/projects
-Each new folder will be the storage location for import directly into Sirikata. (Ex. /Kunst/ for the
Speed Limits Kunst museum project).

/sirikatacontent/scripts/
-Future useage for scripting, maybe CVS files can reside here?

/sirikatacontent/toolbox/
-Not to be confused by Utilities, this is where we drop photoshop brushes, config files, palet files, etc.

/sirikatacontent/utilities/

-All utilities that we are permitted to redistribute that are required by content designers (ogre exporter,
dds plugin, etc)

NOTE: For group projects, make sure that the sirikatacontent folder is placed at the top level of your hard
drive (C:) to avoid any potential file path errors when sharing content with your group.

10



Modeling with Maya
Maya Setup

1. Open Maya and go to Window > Settings/Preferences > Preferences.
e Gconer Catearerate Booanasmidinie
|*/®? a8 &

General Editors

k
I Rendering Editors » 031 Hendering1 FaintE ffen
Animation Editors »
E_ Relationship Editors 7 ﬁ ‘“‘
bl Setti Pref +F -
| Seingspricences ) [ e
| Attribute Editor Tool Settings
Outliner Performance Settings
H h: Hi h
Hypergraph Clerarcctj.,' Hotkey Editor
ypergraph: Connections | caneseming
Paint Effects Marking Menu Editor
UV Texture Editor Shelf Editor
| Panel Edit
Playblast i i
Plug-in M
View Arrangement 3 e

2. There are several changes that need to be made. Under the Settings category, change the
Working Units to “meter.”

Categories Settings: General Application Preferences

Interface .
I Elements ~World Coordinate System »

WiewCube Up axis; & Y [ 152
Help

Display ‘Working Units -
Kinematics =

Arimation Linear: 1_:]

td anipulatars

NURES
Polygorss Angular: | degrees 71
) ] Time: | Fim (24 fps] -

[~ Keep keys at curent frames

iy
Cameras
Dynamics

Filez/Projects
Modeling ~Tolerance

Fiendering Positional:  [0.01000 (]| e

Selection

Shapping T angential: 10.1 ooao e |

Sound 1L

Timeline

Undo

Save Actionz
todules
Applicationsz

Save Cancel
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3. Next, under the Cameras category, change “Far Clip” to 1,000,000 and the “Near Clip” to .001.

NOTE: The screenshot below shows incorrect information, but does show where and how to edit the
Camera preferences. Input the values listed above, not those in the screenshot.

Categories Camera: Default Camera Preferences

Interface
Ul Elements Default Cameras

ViewCube e Imi [
Help Mear clip:  |0.1 | 1]
Dlsplay . Far clip:
Kinernatics

Aniration Animate Camera Transitions

Haggtgatms v Fit wiew

Folugorns W Fit all view
Subdivs ¥ Goto bookmark
Seftings v MextiLast camera view

Frire = ks
[:m’ Total time: |05 — ]
Livrianmncs
Filez/Projects
Modeling
Rendering
Selection
Snhapping
Sound
Timeline
Uhdo
Save Actions
Modules
Applications

Save Cancel




Working in Maya

Harden / Soften Normals:

Maya default assumes that all of your edges are
instances you may want to soften certain edges

hard-edged surfaces when you are modeling. In some
or make certain edges hard. Select the edges to soften or

harden via edge mode, then go to Normals > Soften Edge (or Harden Edge) in the polygon menu.
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Creating Multiple UV sets:

Go to Window > UV Texture Editor
Polygons >Copy UVs to UV Set.

Alternatively you can create an empty UV set,
especially if you need to change the UVs or how
they are laid out.

NOTE: When naming the new UV set, use map1,

map2, map3 for your UV set names.

Subdivs View Select Tool Image Textures UV Sets Help

Wertex Mormal Edit Tool o
Set Vertex Normal o
Lock Normals

Unlack Normals

Average Normals

Set to Face o
Reverse o
Conform

L Soften Edge “

Harden Edge
Set Normal Angle..,

Window | Select Mesh Edit Mesh

General Editors

Proxy MNermals Color CreateUVs Edit Uvs  Help
e aw|EeNyolany BEEE

ics | Rendering | PainEfiects | Toon | Cloth | Fluids | Fu | Hai

pECLk+IR@IrRTiB Y

| -

Rendering Editors
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Animation Editors

Relationship Editors
Settings/Preferences

Attribute Editer

Outliner

Hypergraph: Hierarchy
Hypergraph: Connections

Paint Effects

Playblast

bdivs View Select Tool Image Textures UV Sets Help

\EE
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B

Copy UVs
Paste UV=

Create Empty UV Set
¥ Co 1o UV Set

Set Current UV Set...
Rename Current UV Set.

View Arrangement
Saved Layouts
Save Current Layout.

Frame All in All Views

Copy UVs \lﬁl E Iq- -pl li D:;Z:hze
Paste Vs Fli
— E p

X &

Create Empty UV Set
Copy UVs to UV Set

Set Current UV Set...
Rename Current UV Set...

Rename Current UV Set Options

Delete Current UV Set.

T

Rotate

Cycle UVs
Best Plane Texturing Tool

Grid
Align

‘Warp Imaae

Delete Current UV Set Edit Help

Mormalize Setlings

Unitize Mew LW Set name: Imap2
Flip

Rotate

Fiename Current |
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Assigning Multiple Materials to same Mesh to
Faces (for Max)

In order to help speed up the process of working within
3DS Max, Maya users should utilize assigning different
materials (always phong) to faces that use a different
material, even if they are part of the final object. A case
example would be the Glass of a window within its
frame. The frame has a different material from the glass.

To do this in Maya, simply select the faces that will be the
different material and either choose Assign New Material
> Phong (or Assign Existing Material if you have already
created a material).

Object Naming (mesh names)

It is important to maintain naming for the purposes of
redundancy and knowing what is what. Within Maya
open Window > Outliner and simply double click on the
mesh and rename it accordingly.

NOTE: Naming is important as the end exported FOLDER
to Ogre must be named the mesh name, in this case
/tree_ash01/. (Disregard the file name in the screenshot;
it should be tree_ash01)
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Set Pivot Points

There are several options depending on the workflow of your
scene to set the pivot point.

Primary Example:

A single object for import into Sirikata

Make sure to move the object to the center of the grid. You can
do this by selecting the object, hitting W for translation, and
holding down 'X' to force the object to snap to the grid, then
moving it to the center of the grid.

This centers the object to the world space. In this example the
tree is standing on the grid, this way when moving around in
Sirikata the tree can be placed using its pivot on the bottom,
where it will be across Terrain. With other models you will want
to center the pivot first in the model, then snap the model to the
grid in Maya's World Space.

To Center the pivot of the model, go to Modify > Center Pivot.

After you are completely finished with the mesh, you should
delete the History to clear out any metadata that we don't need
to save. Go to Edit > Delete All by Type > History.

Edit | Modify Create Display Window Select Mesh  Edit Mesh  Prox

=N

1
Ctrl+z |

Undo 2|+|£°|a|.|@|
Redo z Defolmatlon I Apimation I D_\Jnamlc
Repeat "Phong” g

T S

=1

Recent Cormmands List

= Cut Ctrl+x
Copy Ctrl+c
Paste Ctrl+w
Keys 4
Delete
Delete by Type 3

Delete All by Type

Py N R WL TN

Select Tool Mon-Deformer History
La.sso Select. Tool Channels
Paint Selection Tool Static Channels
Select All Clips
Deselect Motion Paths
b Select Hierarchy Mon-particle Expressions
Invert Selection Constraints
' Select All by Type 4 Sounds
Quick Select Sets 3 .
Joints
=  Duplicate Ctrl+d IK Handles
i Duplfcate S?ecml Ctrl+D Lattices
§ Duplicate with Transform D Clusters
'=_ Group Ctrl+g Sculpt Objects
&  Ungroup Monlinears
f Level of Detail 4 Wires
£l Parent P Lights

—
()]

Gereral | Curves | Sutaces | Polygons | Subivs | Defomation | Arimation | Dynamios | Rendeing | PaintEffests | Toon | Ciot

== S T IR

7| View_Shading_Lighting_Show_Renderer_Panels
B0 650

j Autodesk Maya J008:
File Edit | Modify | Create

~\Users\argenex\D

Display Window Se

I Polygons Transfoermation Tools 4

Reset Transformations [m ]
Freeze Transformations [m]

Snap Align Objects 3
Align Tool
Snap Together Tool m}

r-? Evaluate Modes 3
\

Make Live

Prefix Hierarchy Mames...

Search and Replace Names...

Add Attribute...
Edit Attribute...




Transformation Tools 3

:  Reset Transformations
[ Frese Tensomations [
Freeze Transformations  Srap Algn Objets ,
Align Teol

Next is it important to freeze the transformations on the mesh. Do this when | seTogtheroa

you are utterly completed with the mesh, and AFTER you have deleted the [ Eratteodes '
Make Live

History. Go to Modify > Freeze Transformations. Center Pivat

|
Prefix Hierarchy Names...

Search and Replace Names...

Add Attribute...
Edit Attribute...
Delete Attribute...

Convert 3
Replace Objects

Paint Scripts Tool
Paint Attributes Tool

File | Edit Meodify Create Display

. . Mew Scene Ctrl+n [n ]
Export'ng us’ng COLLADA Open Scene... Ctrl+o o
Make sure the object or objects that are finished and ready for export Save Scene Cirlrs o
are selected, and then go to File > Export Selection... A dialogue box will e &

Save Preferences
appear.
. Optimize Scene Size
txport seecton Options ) MR W Ma B0 ls S B e 0 L e W Import
Edit Help "

General Options EXPDI’"Z All...

[n}
[n )
[n}
File type: | COLLADA exporter = Export Selection... E

[¥ Defaul file extensions

View Image...
Relerence Dptions View SEqLIEI"ICE...
-
:: Create Reference...  Ctrl+r [n }
Prefi with: | the file name Reference Editor
Include Options Project i’
= .
r Recent Files »
r
F Recent Projects 4
r
Exit Ctrl+q
File Type Specific Options
j General Export Options
[ Bake transfarms ™ Relative Paths
[~ Bake lighting [Undo to remave baked values) Make sure on |y the followi ng
[™ Export camera as lookat
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™ Samping = Default file extensions (.dae)
Sampling function [
= ¥ Static Curve Remaval - P0|yg0n MesheS

Read the documentation on how to use the variable sampling function.
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[ Invisible Nodes = Export References
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j Camera Options
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IF neither #Fov and YFov are selected, YFov is exported.
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Modeling with 3ds Max
3ds Max Setup

17

Open 3ds Max 9 and go to Customize > Units Setup. Under
Display Unit Scale, select the “Metric” bubble and choose
“Meters” from the dropdown menu. Click “OK.”

Go to Customize > Preferences and select the “Viewports” tab.
Under Display Drivers, choose “Configure Driver...” A pop-up
called “Configure Direct3D” should appear.

In the pop-up, check “Enable Anti-Aliased Lines in Wireframe
Views” under Appearance Preferences, and “Match Bitmap Size
as Close as Possible” under both Background Texture Size and
Download Texture Size. Set the sizes to their highest values,
1024 and 512 respectively. Click OK.




4. Now, go to the “Files” tab. If you’re not very organized, you will want to turn on “Increment on
Save,” which will save each file as 01, 02, etc. Turn on Auto Backup and enter the settings below.

RURKUREURER

r
J |
J |

EN—

-
E0 3

[ o< [ & |

BUG: The Ogre Exporter creates the file MaxStartUl.mnu whenever 3ds Max is closed. This bug is
documented in the Troubleshooting for Ogre Exporter section. Until this bug is fixed, the user must delete
MaxStartUl.mnu or 3ds Max will crash on start up.
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Importing into 3ds Max from COLLADA

1. Open 3ds Max 9 and go to File > Import... Select “COLLADA (*.DAE, *.XML)” as your file type.

2. Navigate to the folder where your COLLADA file is located and select it, then hit Open.

3. Select the model and navigate to the Modify tab on Command Panel. Your object should be listed as
an “Editable Poly.” If not, right click the object and select Convert To: > Convert to Editable Poly.

e MAXScript OgreMax Help

he® g c% of |0

7 emT
e— |

vl )

4. Open the Material Browser by pressing “M” on your keyboard. Use the eyedropper tool and select
your mesh. A new material should appear in the first slot in the browser. This material is created
when exporting a mesh from Maya with COLLADA, and it can cause massive errors. This material HAS
to be deleted before you can go any further.

Material Editor - ash01_phang-fx
Material Utilities

(=] =

Mavigation

Options

“FEO S e HEOO

-
| »

Pe %2 % 1X @4 %o [@ T & &
9% Iash[l'l_phong-h: j Standard

[- Shader Basic Parameters |
IF'thg j [ wire [~ 2Sided
[~ FaceMap [ Faceted
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5.

This is how the material browser will look right after
you use the eyedropper. The problem material, in
this case, is ash01_phong-fx. This name will change
based upon your mesh and assigned material, but will
ALWAYS end in “-fx.”

Select a blank material slot and apply the material to
your mesh. To get rid of the problem material, select
it and push the “X” button above the eyedropper
button. Choose the first option, “Affect mtl/map in
both...” in order to delete the material from both your
Material Browser AND the mesh it is applied to. If
you choose the other option, it will only delete it from
the browser, but its information will still reside in the
mesh.

One problem, however, is that the material still
retains its old name. In order to correct this, click and
drag an empty material slot (any will do) over the slot
with the name ending in —fx. Select the material slot
of the —fx material and make sure there is no
“COLLADA CA” dialogue box. If this is gone, you're
golden.



Working in 3ds Max

Smoothing Groups

Similar to Harden/Soften Normals in Maya,
the Smoothing Groups feature in 3ds Max
determines whether the edge of an object is

#|3|@|@| T

hard, like the edge of a table, or soft, like the

edge of a pillow. Select your object and click

the drop down icon next to “Editable Poly” in
the Modify tab. Select “Polygon.” Navigate to
the “Polygon Properties” section and drop the
menu to find “Smoothing Groups.” Set up
your smoothing groups accordingly, or if you
are importing using COLLADA, make sure that

I.-'i‘-.sh_m |_
IMu:u:Iifier List -]
Bl Editable Paly &

N Wertex
Edge
Barder
FPolpgon =

Element

your smoothing groups have transferred over
correctly from the program you originally
modeled in. This model only has 1 smoothing
group, because it is completely hard edged.

Material IDs

If your object needs to have more than one
material applied to it (for example, a window: 1
material for glass, 1 material for the wood frame).
The Material IDs section is located right above the
Smoothing Groups, under “Polygon Properties”
section. The model | am working with, tree_ash01,
only has one material ID because it only needs one
— the leaves and bark do not require separate
materials because they would have the exact same
material set up. There isn’t a hard limit, but try and
have less than 6 material IDs per object. You are
welcome to try as many as you would like on an
object.

Object Naming

Whether you have imported your file using COLLADA or you started off
in 3ds May, it is important that your object maintains the name

throughout its creation. In order to name your mes

panel. The top input area is your mesh’s name. Change it accordingly.

NOTE: Naming is important as the end folder to whi
your mesh to must be named the same as the mesh
folder would be /tree_ash01/).
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Creating an Object with Multiple Materials

When creating an object with multiple materials, you have to select the individual polygons you would
like to apply the material to. In the image below, I've selected the frame of the window that | want to
have the wood texture applied to. For the Material ID, go to “Set ID.” Enter the number 1 and press
Enter. Select the polygons of the next material and set the ID to 2, etc. Press M on your keyboard to
open the Material browser and follow the steps for setting up a material.

[E) untitled - Project Folder: C:\Users\Ben\Documents\3dsmax - Autodesk 3ds Max9 SP2 - Display : Direct 30 [ |f=] =]
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Map Channels and Multiple UV Sets

For more advanced meshes and materials, multiple UV sets may be required. Unfortunately, 3ds Max has
trouble keeping track of multiple UV sets, or, as it refers to them, Map Channels. If you’ve imported from
Maya using COLLADA, you may want to go through this process just in case. Go to the Modify tab and
apply an “Unwrap UVW” modifier. Create your basic UV and make sure that the Map Channel is set to 1.

v, @ 5@ E| T

I bioe_Livtest .

E ditable Faly

Modifier List j

w11 8l =
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|- Parameters

Edi...

Reset iz | Save. ..

Load...

Charwak —_|
® MapCharnel [T 2] |

" Wertew Lol Lhannel

— Dizplay:
v Show Pelt Seam

IF Chewbdan Casm

Now click “Save...” and save your UV
out as mapl.uvw. Now, right click
on the “Unwrap UVW” and select
“Collapse All.” Confirm and you
should only see Editable Poly left on
the Modify tab. Now, apply another
“Unwrap UVW” modifier and make
sure you change Map Channel to 2.
Now, choose “Load...” and select the
.uvw file you saved out. Edit the UV
as you see fit. You will be applying
specific textures to each UV later.

a.

Map Channel #1: 0 to 1
textures

Map Channel #2: Tileable
textures.

Map Channel #3: Grunge
maps



Creating .DDS Textures for 3ds Max and Sirikata

All textures need to be converted into .dds files using the NVidia plugin prior to exporting the model from
3D Studio Max. The link to the plugin is provided in the Basic Requirements section.

Texture Map Creation

1. Start Photoshop and open your texture file.
2. Keep master files for all textures at 2048x2048, or if possible 4096x4096. All textures must be in

powers of 2 (e.g., 2x2, 512x512, etc.)

3. Before saving your file as a .dds, go to Layers > Flatten Image. Make sure there is only one layer

when you go to save.

4. Go to File > Save As > and choose .D3D/.DDS
a. For almost all texture maps save as a DTX1
b. Have Generate MIP maps radio on for ALL TEXTURE MAPS
c. Click Image Options and at the bottom check on Pre Modulate Color

NYIDIA dds Format ¥8.23
Save | Cancel |
|DXTl RGE 4 bpp | no alpha j
MIF Map Generation
eliTe=tirs j + Gererate MIP maps
s All =
MIP Map Filtering... | Sharpening... | £ Use Existing MIP maps
" Mo MIP maps
Image Dptiohs... | MNormal Map Settings... |
Fading MIP maps... | wirite Config. .. | T | Eel

Read Config...

Refrezh Presiew |

Prewview Options. .. |

Profiles

Set Profile Directory

Save Profile
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Normal, Occlusion, and Alpha Channel Textures

1.

Normal Map

a.

D Qoo oT

Create your normal map using Crazybump or the NVidia Normal Map filter.
Open your Channels browser by going to Windows > Channels or clicking the Channels tab.
Right click the Red Channel and choose “Duplicate Channel...” Name it “Alpha.”
Hide the “Alpha” Channel and select the RGB Channel.
When you Save As > .dds, be sure the Alpha box is checked.
For Normal maps save as a DTX5 interpolated alpha (DO NOT use DXT5_NM)
i. Use DTX3 explicit alpha if you don’t want any gradient on your alpha borders (either
ON or OFF)

CHAMMELS
Ctrl+2
Ctrl+3

Ctri+4

Ctrl+5

2. Ambient Occlusion

3.

24

a.

b.
C.
d.

Create an Alpha Channel

Create a B&W grayscale Alpha mask, and copy it into the Alpha Channel.

When you Save As > .dds, be sure the Alpha box is checked.

If your Ambient Occlusion map has an alpha in the Alpha Channel, save the file with DTX5
compression (DO NOT use DXT5_NM).

Alpha Channel Texture (such as foliage, glass)

a.
b.
C.

Prepare your texture and its Alpha Channel.
Save as DXT3 or DXT5.
When you Save As > .dds, be sure the Alpha box is checked.



Material Creation in 3ds Max

Material Map Slots Explanation

When creating materials, all texture files loaded need to be in .dds format. To open the Material browser,
press “M” on your keyboard. Underneath Shader Basic Parameters should be the Maps section. Drop
down the menu to see all the available map slots. Below are detailed descriptions about the types of
textures you would put into which slots.

Diffuse Color:
Your Diffuse map goes here. This Map slot has the most versatility for combining multiple Color
Maps, Dirt Maps, separate Ambient Occlusion Maps, and so on. Detailed Material creation
combinations are covered later.

1. For a basic Diffuse texture, click the map slot next to Diffuse Color and choose “Bitmap.”

Ambient Occlusion: - =
1. If you have an ambient occlusion map, choose Difuse Color._ % JA0DGing - RGB Wil |
“RGB Multiply” instead of “Bitmap” for the E Al LUliph ErEraiE |
Diffuse Color. M aps
2. Color #1 is always the Ambient Occlusion Map. Color #1: | 1gWaII_taII_D'I_F'ierLow_D'l_.-’-‘n.D.dds]| v
In the map slot, pick “Bitmap” and choose your Color #2: |
Ambient Occlusion .dds file.
3. Color #2 can be any of the following: Alpha From:
a. Your Diffuse texture, loaded as a £ Map #1
Bitmap, or combined with other £ Map 2
textures, such as grunge maps, through & Muliply Alphas
RGB Multiply, Composite, or Mix.

DiffGrg [ BGE Multiply | | rd

Specular Color:
1. Choose “Bitmap” and select your Spec Map texture.

Self lllumination:

Leave at 100%. The amount of glow your material will have will be based on the texture itself,

not the map slot percentage. Note you must also turn on Phong Basic Parameters > Self-

lHlumination > Check Color and change the color picker to pure white.

1. Choose “Bitmap” and pick your Glow Map texture.

2. If there is no Diffuse Color Map, then embed the Alpha in this slot.

3. Filter Color: Check this on and it will be the HDRI Glow Map, it is Self Illumination/Filter
Color amount. Actual Glow amount is determined by the percent of Field of View in Sirikata.

Opacity:

1. Check it on, but this map is only needed to display properly in Max.

2. Ifit has an Alpha, it must match the map channel of the Diffuse Texture Map in the Diffuse
Color slot, and the Opacity slot must use the same Diffuse Texture Map.

3. The textures won’t be loaded twice by the engine
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B %, |NomBump ~|  Marmal Bump
Bump: E Parameters |
Both the Normal Map and Bump Map go into N Norbin (Mie) |7 1T 2]
this slot. Select “Normal Bump” instead of Adional Bump: a1, 01_PieLow_01_BMP.acs)| ¥ [T 3

ups ”n
Bitmap”, and enter the Normal map under the e Bl ——
Normal slot. If you have a Bump map as well, I Fiip Red (<] @ Tangent
. . . =
enter it under the Additional Bump slot. M i Eian A
[7 Swap Fedt Green
1. Tangent Space  Warld

2. Extra Expensive with Dirt Channel

Reflection:
Enter the Environment cube Map in this slot. Good for large interiors and reflective objects.
There is very little cost to the engine when rendering these.

Steps for Creating a Basic Material

To create a simple material, like the one to the

right, is quite simple once you have all your & tree_ashll_phong [ Standard |

textures saved in .dds format and your UVs set up B Diffuze Color: Map #9 [ RGE Multiply |
properly. Open the Material Browser and select a @- Color 1: Map #10 [ree_ash1_AD dds)
blank, empty material. Under Shader Basic L Color 2 Map #11 [ree_ash01_COL dds)
Parameters, change “Blinn” to “Phong.” Following ... Specular Color: Map H8 [tree_ash(01_SPC.dds)
the Material Map Slots Explanation guidelines, set . Opacity: Map #4 [ree_ash01_COL dds)

up your texture maps accordingly. Rename the T Burnp: Map #5 [ Normal Bump |

material in a way that will make sense to whoever mr bap #7 [tree_ashil_NRM.dds)

opens the document. The sample material, to the L Map #5 [tree_ashEH_EMF".dds]

right, belongs to the mesh tree_ash01. Thisis a
rather simple material. It has all the basic materials
your model will need to look good.

Steps for Creating a Multi Sub Object Material

Multi-Sub object materials are often used in conjunction with Material IDs. They allow for you to group
multiple materials under a header, allowing you to apply all the sub-materials to a mesh in one go. One of
the perks of this is that the sub-materials can still exist in the Material Browser in separate slots, allowing
you to work on individual materials and simultaneously update the Multi Sub object material at the same
time. In the Material Browser, select a new material.

Below the material slots, you should see a button that I J M ame | Sub-h aterial |

says “Standard.” Click this and choose “Multi/Sub- ' "1— I— Material #0 [ Standard | |
Object.” You will now see multiple slots for materials.

Drag materials that you have made in into the slots. - |2_| b atenial #1 [ Standard | |

Next to the slots you will see a space for input under

“ID.” This is where you will state the Material ID for each of the materials you place in your Multi Sub
object. So, if | were to apply this Multi Sub material to my model, which has two Material IDs, which ever
material is in slot #1 of my Multi Sub object will be applied to the polygons with Material ID #1, etc. If you
have an object with multiple Material IDs and materials assigned, you can use the eyedropper to
automatically create a Multi Sub Object material for you. If your object has multiple UV sets that were set
up earlier, you can tell your “Bitmaps” which Map Channel to use by entering the Map Channel number in
the dialogue box.
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Example of an Advanced Material

This Multi-Sub object material shows the power of the Material Browser. | will not provide step-by-step
instructions explaining how to set up the material; rather, to the right is an image of the material’s tree,

showing you each of the individual parts that has gone into making each material. You should be able to
look at this and reverse engineer it using your own textures.

@ RetwfalT all [ kMultifSub-0bject ]
- 1] Bot: Rebw/allT alBot [ Standard |
@' Diffuze Color: A0_Diff_Grng [ BEE Multiplhs ]
L Color 1: AOUNVY [Retaining's/all_tall_01_PierLow 07_AD0. dds)
@' Color 2 DiffGrg [ RGE Multiphy
{%‘ Color 1: Diffbdis [ bix ]
i @ Colar 1: Oiff_MainlV2 [StoneladelleSat_a 07,02 dds)
@ Color 2 Diff_Mazked 2 [Mozs_Main_a_01.02_COL. ddz]
: b Mix Smount; Map B4 [Fetaining'w'all_tal_07_PierLow_01_&0.dds)
LB Color 22 Ginglv3 [Grunge_Leaking_a_01.02 dds)
- Specular Color: SpecRGEMult [ RGE Multiph )
& Color 1: SpecMix [ Mix ]
@' Color 1: Spec_MainllY2 [StoneladeDe5at_a 01 _SPC dds)
f@ Color 2 Spec_basked V2 [Mozz Main_a 01.01_SPC.dds)
AT Mix Amount; Map #5 [Fetainingwial_tal_07_PierLow_01_a0.dds)
@ Color 2 Specirmng U3 [Grunge_Leaking a 01,02 ddsz]
-8 Bump: MormBump [ Mormal Bump |
- - Mormbdix [ Mix ]
f@' Color 1: Morml 1 [Retainingtsall_tall_01_FierLow_01_MHERM.ddz]
@' Color 2: MomlV2 [StoneladeDeSat_a 01 WA dds]
Lo Mis &mount: A08IphaM orm_Masked W [Retainingwall_tall 01 PierlLow 01 A0 dds)
8 : Burnpl%1 [Retaining'fall_tall_01_PierLow 01_BMP.ddz]
.43 [2] TopBronze: Retw/allT allTop_Bronze [ Standard |
-8 Diffuze Color AD_Diff_Grmg [ RGE Multiply
8 Color 1: A0 [Retainingtsall_tall_01_PierLow_01_AD dds)
- Color 2 DiffGrg [ RGE Multiply ]
- Color 1: DiffMiz [ bix ]
1@ Colar 1: Oiff_Mainlt2 [StoneladelleSat_a 07,02 dds)
1@ Color 2 Diff_Mazked V2 [BronzeGungeOxid_a_01.01_COL. ddz)
LB Mis Smount; Map B2 [Fetainingywall_tal_07_PierLow_01_&0.dds)
@ Color 2 GrglW3 [Grunge_Leaking_a_07.02. dds)
- Specular Caolar; SpecRGEMult [ RGE Multiplh )
43 Color 1: Speckix [ Mix ]
@ Color 1: Spec_Mainl V2 [StoneladeDeSat_a 01_SPC ddz)
w8 Color 22 Spec_Mazked 2 [BronzeGmngelxid_a 01.01_SPC.dds]
i Wi Amount: Map #3 [Retaining'w!all_tall_01_Pierlow 01_AD ddz)
3 Color 2 Specirmg W3 [Grunge_Leaking a 01,02 ddsz]
-8 Bump: MormBump [ Mormal Bump |
5 - Marmbdix [ Mix ]
f@' Color 1: Morml 1 [Retainingtsall_tall_01_FierLow_01_MHREM.ddz]
@' Color 2: Morml V2 [StoneladeDeSat_a 01_MAM dds]
LA Mix &mount: A08IphaM orm_Masked W1 [Retainingw/all_tall 01 PierlLow 01 40 dds)
8 : Burnpl% [Retainingfall_tall_01_PierLow 01_BMP.ddz)
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Hard Rules for Material Creation

1. Maximum Maps per Material is 10
a. The maximum number of unique texture maps on any material is 10

2. Certain Materials Are Applied to Specific UV Sets
a. Asda

3. Match the Diffuse and Specular Maps in order, Material Type, and UV Set #'s
a. The structure of the maps for the Diffuse texture (after the AO RGB Multiply) and Spec should be
the same.

-3 [1] Bot: RetwallTalBat [ Standard |

- Diffuse Color: AQ_Diff_Grng [RGE Multiply |
@' Color 1: A0 [Retaining all_tall_01_Fierlow_01_20 ddsz)

- Color 1: Diffkdie [ Mix ]

o Color 1: Diff_Mainl2 [Stone) adeDieS at_a_01.02.ddz)

il Color 2 Diff_MaskedUW2 [Moss_Main_a_01.02_COL.dds)
- Color 2 Grngl%3 [Grunge_Leaking_a_ 01.02 ddz)

- Specular Color: SpecRGEMult [ RGE Mulbiply |

idf Color 1: Spechin [ Mix ]

{ L Color 1; Spec_Mainlv2 [StoneladeDeSat_a_01_SPC.dds)

- Color 20 Spec_Maszked W2 [Mosz_Main_a 01.01_5PC.ddz]

¢ e Mix Amount: bap #5 (Retainings/all_tall_01_Fierlow_01_40. dds]
ol Color 2 SpecGimg_ U3 [Grunges_Leaking_a_01.02.dds)

-&F Burnp: MormBurnp [ Marmal Burnp )

@' Mormbdiz [ Miz ]

P O B TR T R N S

4. The AO alpha channel will always be applied to the 2" material
a. Except the Normal

5. One Bump Map Allowed
a. The Bump map is by far the most expensive texture map to use (only if you have more than one
UV set)
b. Never try to use more than one, and if a Bump doesn’t provide enough effect, do not use it at all.

6. Map #2 for all materials must have matching UV Sets/Map Channel

7. UV Set #2 and #3 should be upright (perpendicular)
a. Tiling UV Set #2 should usually be upright (not rotated) and scaled to the correct Units
(Determined by the size of your materials and the objects that are sharing those same materials).
Most tileable textures are designed to tile in the upright position. If one makes a texture that
runs parallel to the ground, then consult with the art team before completion.
b. This should also keep normals aligned to the tangent space.

8. Maximum of 3 UV Sets
a. Use up to 3 Map Channels and no more.

9. Alpha Channels (Making Masks)
a. To make your Texture Map use and Alpha it must have the following radio buttons checked un
the Bitmap Parameters dialog
i Mono Channel Output: Radio on for Alpha
ii. RGB Channel Out: Radio on for Alpha as Gray
i Alpha Source: Radio on for Image Alpha
V. Check on Premultiplied Alpha

28



b. To make a texture with an Alpha do the following:
i Load your texture with the alpha channel into the Opacity slot under Maps, check it
on, and make sure it is 100 for the Amount
iil The texture one uses for the Opacity slot must be the same map used in the first
Diffuse Color slot.
iii. They must also use the same UV Set.
c. If your Material is 1-Sided (only visible from one side), it will not count as a new Material
d. If your Material is 2-Sided (only visible from one side), it will as a new Material. Check the Make
2-Sided (See Fig 3) box under Shader Basic Parameters.

10. Only 3 of the following Maps can be used on a given material
Glow
3" Spec
3" Diffuse
2" Normal
Reflection
Addtionally, only 2 of the following maps can be used on a given material
i Glow
ii. 3Spec
iii. Reflection

S0 Qoo T

11. Specular Color can’t have more maps than in Diffuse Color
12. Cost Considerations

a. Little Glow & AO
Each new UV Set is another Multiple for the cost of a bump
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Sirikata Material Types

1. BASIC MATERIAL

@ Bazickat_MoAD [ Standard |
LT Diffuze Color: BasicDiffuze_Mod0 [Boulder_ Rocky 01 _COL.dds)

Limitations: This material cannot use Ambient Occlusion, glow, reflection, environment, or grunge maps.

2. BASIC MATERIAL, with Normal but no Bump

@ Bazichtat_MoBump [ Standard |
-3 Diffuse Color: BasicDiffuse_NoAD [RGE Multiply |
.. Color 1: BasicaD [white.dds)

B Specular Color: BazicSpec [Boulder_Rocky 071_SPC.dds)
B Self-llumination: BasicGlowe_MNoGlow [black. dds)
-3 Bump: BasicHmBump_NoBump [ MNaormal Burmp |

Limitations: This material cannot use Ambient Occlusion, glow, reflection, environment, or grunge maps.

3. SINGLE DIFFUSE, Max Detail
One Diffuse with Ambient Occlusion and Grunge and Additional Normal on UV Set 1

@ ManDetailbat [ Standard |
- Diffuze Color: BasicDiffuze [ RGE Multiply |
L Color 1: BasicAO_Uvzet] [box_uvtestdl A0 dds)

- Specular Color BazicSpec [ RGE Mulkiply |

-8 Color 1: BazicSpec [Boulder_ Rocky 01 SPC dds)

3 Color 2 Grunge_Veet3 (Grunge_General_a 02 ddz)
¥ Bump: BazickrmBump_MoBump [ Mormal Bump |

-~ BazsicNRM [ Mix ]

L& Color 1: BazicMRM_Uvzet] [Focky a_01_MRM.dds)

3 . Bump_LWSet] [Boulder_Rocky 01_BRP.ddz]
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Working in 3ds Max, cont.

Setting the Pivot Point

Once you are COMPLETELY finished modeling, you’ll need to make sure
the pivot point is set up properly. The pivot point determines how your
object is moved within Sirikata. While it can be placed anywhere you
choose, in order to avoid possible errors, the pivot point should always
be placed at the base of the object. Make sure the bottom of your object
is touching the grid, or is extremely close. Go to the “Hierarchy” tab,
select “Pivot,” then “Affect Pivot Only” under Move/Rotate/Scale. Now,
make sure you are using the “Move Tool.” You should see
the Move gizmo, but it will look a little different than normal |‘ ‘$’
because you are affecting the pivot point of the object

rather than the object itself. Now, set the Z value (the

height) of the pivot point, if it is not already, to 0. The pivot point of the
object should now be the object’s base, and on top of the grid.

-

Perspective

¢ | 0./ 100 | > |

w| o2 @@ T |
[#:sh_01 [

" Pt K| Linklnfo |

B Adjuzt Pivot |

Move/Rotate/Scale:
| Affect Pivat Only
Affect Object Only |

Affect Hierarchy Only |

=2 IIIIIIIIIIE:IDIIIIIIIII4!DIIIIIIIIIE!DIIIIIIIIIqII_IIIIIIIIII1$D

‘ S [&] ®foo 2)vfoo 2llon
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File Edit Toeols Group Views Create Modifiers  reactor  Animation  Graph Editers  Rendering  Customize  MAXScript

P RIH R S B Lie e DAl STl e’ &

|
e | ] @[ T
i [sh_o1 B
)‘\ [- Utilities |
Mare. .. Sets | @

Azzet Browser

Camera Match

|

|

Collapse |
Calar Clipboard |
|

i

Meazure

Mation Capture

: Reszet xFarm

MK cript |

reactor |

[| = Reset Transform |‘

Reset Selected |

Reset XForms

Once you have set the pivot point, you're ready to do the last step before exporting. You need to reset the XForm
of your object. Go to the “Utilities” tab and select Reset XForm. Make sure your object is selected and then
choose “Reset Selected” under Reset Transform.

Go to the Modify tab. There should be a new XForm i | W“ﬂ n’E‘n| (@‘ ‘ T |

modifier on your object. When you select it, there [fsh_o1 |_
should be an orange selection box around your
object. If so, the Reset XForm worked. Right click IM':'diﬁE' o j
on the XForm modifier and choose “Collapse All”
from the drop down list. You should be left with an Editablz Pol Rename
Editable Poly; if not, convert your object back to Delete
one. —
Copy
Paste
== ||T | Paste Instanced
—_— Make Unique
Collapse To
Collapse All
v Preserve Custom Attributes
Retain Subfnim Custom Attributes
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Exporting from 3ds Max

Once you have your materials set up and gone through the other required steps, you’re ready to export your
object using the Ogre Exporter. Select your object and go to OgreMax > Export Selected 0.1.3. Create a new folder
under SirikataContent/Models and name it the same name as your object (in my case, tree_ash01). Save your
.scene file in this new folder. 3ds Max will begin exporting. This can take a minute or two. If you check the folder,
you should have a .scene file and three folders: exportlogs, materials, and models. Now you can try importing your
object into Sirikata using the drag and drop feature. If it doesn’t appear, check that you have named all your files
correctly and that all your materials were in the correct folder when you exported.

File Edit Toels Group Views Create Modifiers reactor Animation Graph Editors Rendering Customize MAXScript IOgleMal( Help

(AR TLE LIS O AN TIE| £ e g oo

Scene Settings...

=
Q|ﬂ|u€h|(@|| T| Object Settings...
[f&sh_on =
[ Moxiier Lit ~|
_ Corstraints: INone 'I
I~ Preserve Uis g
Create | Collapze |
Attach |I:I| Detach |

Slice Plane | I Split

Slice | Fieset Flane |

E R = Quickslies | cw |
MSmoath ||:|| Tessellatell:l|

About OgreMax...

B Selection | Make Planar ﬂ ﬂ g
ST View Aign | Grid Align |
I~ Bufertes Felax g
I lanare Backfacing Hide Selected| | Unbide &l |
I~ ByAnde: [45.0 J Hide Unselected
Shirk | Grow | Hamed Selections:
Ring ﬂ Loop ﬂ Copy | Faste |
< | 0/100 |» | ‘whole Obiect Selected ¥ Delete [solated Yertices
= TTTTTTITT T T I I T I I T T I T I I T IT T I T I TTITTTTITdTd = -
= 20 a0 &0 e 100 W Full Interactivit
‘ & = v z [Gid=100 duto Key| [ Selected <] b | ] ue |we | SH LS
” Expart Scene Selection |$ | Add Time Ta Setkey lr: Key Filters... | b2 ||D £| & |> w 'G‘
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Installing and Running Sirikata

Installing Sirikata

1. For 32-bit users: Go to C:\Program Files\ and create a Sirikata folder. Skip to step 3.

For 64-bit users: Go to C:\Program Files(x86)\ and create a Sirikata folder.

Go to http://www.sirikata.com/builds/ and download the latest build of Sirikata.

Open the .zip file and go down one directory to get to the folder which contains sirikata.bat.

Copy the contents of this folder into the Sirikata folder you created.

If you have an older version of Sirikata installed already, give Windows permission to overwrite the files.
Delete the file ogre.cfg.

NoukwnN

Running Sirikata

1. You need to be on the internet to access Sirikata, so much sure you have an active internet connection.
2. Double click sirikata.bat and let it load. Do not close the cmd.exe, the DOS window running in the
background.
3. A configuration screen should appear, titled OGRE Engine Rendering Setup and choose the correct
options. (See Fig)
a) Rendering Subsystem: Direct3D 9 Rendering Subsystem or OpenGL
b) Anti-aliasing: Whatever your GPU can handle
c) Full Screen: No
d) Video Mode: Whatever resolution your monitor and GPU can handle
4. Click “OK.” The settings window will close and Sirikata will open.
5. It can take as long as a couple of minutes for the engine to load. Be patient.

Navigating Sirikata

Sirikata currently uses keyboard commands for all controls. A Ul will be added soon.

Camera Movement

You can navigate scenes in Sirikata in a way similar to Second Life using the arrow keys on your keyboard.
=  Up — move forward

=  Down — move backward

= Left — pan left

=  Right — panright

=  Page up — move up

=  Page down — move down

= Shift + left — slower pan left

=  Shift + right — slower pan right

= Left mouse click + drag — change camera angle

Object Manipulation (Using left click and drag on mouse)
= W — move selected object mode
a) default behavior — move object in sync with mouse, i.e. on a plane parallel to the camera plane
b) with SHIFT key down — move object along X axis
c) with CTL key down — move object along Z axis
d) with SHIFT+CTL key down — move object along Y axis (vertical)
e) with ALT key down - slower, finer movement
= E — rotate selected object mode
a) default behavior — rotate object about Y axis (rotate in place while standing on the ground)
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b) with SHIFT key down - rotate about the X or Z axis. Which one is used depends on the orientation
of the camera with respect to the bounding box. This is difficult to explain but is intuitive in practice.

c) with CTL key down — will rotate about the other axis.
d) with ALT key down - slower, finer movement

= R — scale selected object

= G - group selected objects

= Alt+G — ungroup

= Enter — enter group (selection is quirky)

=  Esc — exit group

= D — duplicate selected object

= B - create light

Scene Save/Load

= CTRL+S — This will save a new file, scene_new.csv. To load this file the next time Sirikata runs, backup your
current scene.csv file and rename scene_new.csv as scene.csv.
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Loading Scene Files

1. Inorder to determine which scene to open, Sirikata searches for the file scene.csv in the main folder. This
file tells Sirikata what to load and how to load it. Of course, in order to load a scene, you must have all
the content files in the correct location for the scene to run. If you are sure you have all of the textures,
meshes, sound files, etc. downloaded, you may open that scene.csv.

2. Backup your current scene.csv by renaming it scene_backup.csv or whatever name you like, such as

scene_BornholmKunstMuseum.csv if you are backing up the Bornholm Kunst Museum scene.

Download your new scene file from http://www.sirikata.com/builds/scenes/.

Rename whichever file you download as scene.txt and drag it into the Sirikata directory.

5. Runsirikata.bat and the new scene should load.

w

&

W1 Sirikata .- - - (oo (-
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Importing into Sirikata

37

1.

2.

w

7.

Go to the directory where your Sirikata source files have been placed (normally C:\Sirikata).

Make sure you have the correct scene.txt ready so that you will import your object into the correct scene
file.

Open sirikata.bat and wait for Sirikata to load.

Once your scene has opened, go the folder where your Ogre file folder should be located (normally
C:\SirikataContent)

Drag the Ogre file folder into Sirikata. | am importing the file tree_ash01, an ash tree, so | am dragging
the entire tree_ash01 folder that the Ogre Exporter created onto my Sirikata window.

Using the keyboard commands, move your object through the scene or manipulate it using scale and
rotate.

Once the object is set up as you like it, you can save your scene by pressing Ctrl + S. The file will be saved
as scene_new.txt in your Sirikata directory so that it does not over write your current scene.txt file. Make
sure to rename your files if you want to load the updated version next time you load Sirikata.
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