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Introduction 
 
This document is designed for users to introduce themselves to the 3D production pipeline of 

Sirikata, a BSD licensed open source platform for games and virtual worlds.  The various articles in this 
document will teach you how to prepare and import your 3D assets so that they may be viewed correctly 
in the engine.  While Sirikata was designed so that even casual users may access virtual worlds, to create 
content for it is a more challenging task that requires at least an intermediate knowledge of such 
programs as Photoshop and 3D Studio Max 9.  You should feel comfortable using the interfaces within 
these programs, including such activities as installing plugins, importing/exporting files, etc. 

 
The 3ds Max Exporter for Sirikata is designed to take the object and shader set up from 3D Studio 

Max directly into Sirikata and maintain the Material settings and properties. Users of other 3D packages 
such as Maya, XSI, etc, can model, UV Map (up to 3 UV sets), export the mesh using Collada, and import 
the mesh into 3ds Max.  Assuming the user has their mesh in 3ds Max, we have provided this workflow 
document to guide users in the creation of Materials in 3ds Max. Users can then take their 3D meshes 
specifically optimized for Sirikata, and export them using the provided plugin. 
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Basic Requirements 
The evolving content production pipeline currently uses these programs and plugins in order for you to 
produce content for the engine. 
 

• Adobe Photoshop CS or later 
• 3D Studio Max 9 32-bit 
• Latest version of Sirikata 
• NVIDIA dds plug-in is for Photoshop to convert all texture maps into the .dds format.  
• COLLADA for Maya  - Currently most of our art team works in Maya for modeling and UV 

mapping, using COLLADA to export the mesh for 3ds Max. 
• COLLADA for 3ds Max 9  - Used to import COLLADA files into 3ds Max.  
• Ogre Exporter for 3ds Max 32 bit is a custom built exporter for the Sirikata engine by our team.  

 
Optional Tools: 
•  Crazybump, a texture generator that uses a diffuse texture to create normal and specular maps.   
• NVidia Texture Tools 2, a standalone version of the NVidia plugin for Photoshop that is GPU-

accelerated. 
• MysticThumbs allows you to see .DDS files as thumbnails in Windows Explorer.  It has both 32 bit 

and 64 bit versions, unlike NVidia’s own thumbnail extension. 
 
 

Example Files 
Along side this .PDF file, you’ve probably noticed a folder titled “example_files.”  Inside this folder you will 
find subfolders, each with specific files for each program.  These folders have been included along with 
this document so that if you find yourself confused at any point, you can refer to our own files in order to 
try and figure out where you may have made a mistake.  The guide was made using these files, so for 
those of you who are importing into Sirikata for the first time, it may be a good idea to follow along with 
the guide and use the example files. 
 

http://sirikata.com/builds/�
http://developer.nvidia.com/object/photoshop_dds_plugins.html�
http://sourceforge.net/projects/colladamaya/files/COLLADAMaya%201.4.1%20plug-ins/ColladaMaya_FREE_3.05B.exe/download�
http://sourceforge.net/projects/colladamaya/files/COLLADAMaya%201.4.1%20plug-ins/ColladaMax_FREE_3.05C.exe/download�
http://www.sirikata.com/res/dev_preview/SirikataSceneExporter.zip�
http://www.crazybump.com/�
http://developer.nvidia.com/object/texture_tools.html�
http://mysticcoder.net/mysticthumbs/�
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Plugin Installation 
Sirikata requires a number of plugins in order for your content to be imported into the engine.  Instead of 
supporting multitudes of file types, these plugins allow for us to ensure that there is a standard way of 
creating content for Sirikata so that everything is uniform, making it easier to pinpoint problems (should 
there be any). 
 

Installing the NVidia .dds file format plugin for Photoshop 32-bit 
1. Go the NVidia plugin page and download the latest version. 

 

 
 

2. Once you have downloaded the plugin, follow the on screen instructions for installation. 
3. You will be asked to choose a folder for installation.  It will use the default Adobe directory.  If 

you have installed Photoshop anywhere else, please change it accordingly. 
4. Finish the installation and open Photoshop.  Go to File > New and create a new, blank document. 
5. Go to File > Save As… and choose D3D/DDS (*.DDS).  If you see this option, that means the 

installation of the plugin was successful. 
 

 
 

http://developer.nvidia.com/object/photoshop_dds_plugins.html�
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Troubleshooting for NVidia .dds plugin 
1. The plugin does not work with 64-bit versions of Photoshop.  If you have a 64-bit version of 

Windows, you will need to install the plugin for the 32-bit version of Photoshop, installed by 
default in C:\Program Files (x86)\Adobe. 

2. If you cannot choose .DDS from the Save As… menu, the plugin may not have been installed 
properly.  Go to your Photoshop folder, normally located at C:\Program Files\Adobe, or 
C:\Program Files (x86)\Adobe for 64-bit users, and open your Photoshop directory.  Go to Plug-
ins and then File Formats.  Inside this director you should see a list of files with the extension 
.8BI.  You should see the file dds.8BI.  If not, run the installer again and make sure you install to 
the right directory (the installer wants the root directory of Photoshop, so always install to there: 
C:\Program Files\Adobe\Adobe Photoshop CSX). 

 
 

Installing the Ogre Exporter for 3ds Max 9 32-bit 
1. Download the Ogre Exporter for 3ds Max 32 bit from the Sirikata wiki. 
2. Open SirikataSceneExport.zip and open the folder “OgreExporter.” 
3. Navigate to your 3ds Max 9 folder, located at C:\Program Files\Autodesk\3ds Max 9 for 64-bit 

and C:\Program Files\Autodesk\3ds Max 9 for 32-bit computers. 
4. Open the 3ds Max 9 folder. 
5. Go back to SirikataSceneExport.zip and copy the contents of “OgreExporter” into the main 3ds 

Max 9 folder. 
 

 
 

6. Give Windows permission to overwrite any necessary files. 
7. Start 3ds Max and open your file.  When it is ready to be exported, go to OgreMax > Export 

Selected 0.1.3. 
8. THE OGRE EXPORTER CAUSES 3DS MAX TO CRASH ON STARTUP.  READ THE 

TROUBLESHOOTING SECTION FOR MORE INFORMATION. 

 
 

http://www.sirikata.com/res/dev_preview/SirikataSceneExporter.zip�
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Troubleshooting for Ogre Exporter 
1. The exporter currently has a bug which our team has been unable to fix.  Every time the exporter 

is used, 3ds Max creates a .mnu file.  The file, MaxStartUI.mnu, causes 3ds Max 9 to crash the 
next time it is loaded unless you delete MaxStartUI.mnu prior to opening the program.  It is 
suggested that you make a shortcut to this folder and keep it on your Desktop or with your other 
Sirikata files so that it is easy to access.  A fix for this problem is underway and will be released 
ASAP.  The location of the folder varies depending on whether you are using XP or Vista. 

a) Vista:  C:\Users\YourAccount\AppData\Local\Autodesk\3dsmax\9 - 32bit\enu\UI 
b) XP:  C:\Documents and Settings\Administrator\Local Settings\Application 

Data\Autodesk\3dsmax\9 - 32bit\enu\UI 
2. If you have any other problems with the Ogre Exporter, you may have installed it wrong.  Make 

sure that the file OgreMaxSceneExporter.gup is in the plugins folder, found at C:\Program 
Files\Autodesk\3ds Max 9\plugins.  If the file is located in plugins but you are still having 
problems, read on below. 

3. Even if all of the Ogre Exporter files appear to be in order, if it does not appear as it should within 
3ds Max 9, try reinstalling the plugin by copying all the files over again.  You may have originally 
placed them in the wrong directory. 

 
 

Installing COLLADA for 3ds Max 9 32-bit 

1. Download COLLADA for 3ds Max 9.  Under the dropdown menu COLLADAMax 1.4.1 plug-ins, 
choose ColladaMax_FREE_3.05C.exe.   When you open this file, it should automatically find your 
3ds Max 9 file folder. 

2. Follow the on screen instructions.  You will be prompted to choose if you want to install the 
plugin for more than one version of Max.  You may install as many options as you want as long as 
the plugin is installed for 3ds Max 9. 

3. Open 3ds Max and go to File > Import.  You should be able to choose “COLLADA (*.DAE, *.XML)” 
under the file type options. 

 
 
 

Installing COLLADA for Maya 

1. Download COLLADA for Maya .  Under the 
dropdown menu COLLADAMaya 1.4.1 plug-ins, 
choose ColladaMaya_FREE_3.05B.exe.  When 
you open this file, it should automatically find 
your Maya folder. 

2. Follow the on screen instructions.  You will be 
prompted to choose if you want to install the 
plugin for more than one version of Max.  You 
may install as many options as you want as long 
as the plugin is installed for your version of 
Maya. 

3. Open Maya and go to File > Export Selected.  
You should be able to choose “COLLADA” under 
file type options. 

http://sourceforge.net/projects/colladamaya/files/�
http://sourceforge.net/projects/colladamaya/files/�
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Project Setup 

Naming Conventions 
It is imperative to have a basic understanding of file organizing and naming that is intuitive enough for 
most content creators to readily access content for use. For the purposes of Sirikata Content development 
and utilizing the import pipeline we are sharing the method we utilize for current projects in an attempt 
to help guide future developers. 
 
NOTE:  If you are sharing files with a group, place the date at the end of the file name (e.x. 07_29_09) 

Mesh Naming 
Mesh names within various 3D programs may be named in various fashions, for example in Maya you may 
rename an object "Object1" and Maya still maintains a sub meta-data called "Object1Shape". In any 
regard it is recommended to artists to control their naming to help prevent future confusion or conflicts. 
 
In the following example each mesh is named finally within 3DS Max before exporting using the Ogre 
Exporter plugin. This way, the mesh name and the folder name of the exported mesh, materials, and so 
forth are contained within the appropriate folder of the name of the mesh. The method of naming is as 
follows: 

 Material (Material Object is made out of NOT 3D/2D material - glass) 
 Type (window or win) 
 Structure (skylight or skylgt) 
 Structure Type (if applicable - bubble) 
 Project (if applicable; e.g., Kunst Bornholm Museum) 
 Version # or Iteration 
 
The example below is specifically the glass, and only the glass, used for the bubble type skylight of 
Bornholm's Kunst museum: 
glass_window_skylight_bubble_kunst01 
 
The frame for the skylight would be named as follows: 
frame_skylight_bubble_01 
 
It may not always be necessary to include the project name as this skylight can be reused, along with its 
glass component, within any project. 
 

Texture Naming 
The method for naming textures is similar to naming models. There are, however, key components that 
are required to maintain consistency between the various types of texture. They are abbreviated as the 
following: 

 Color / Diffuse Map - COL 
 Ambient Occlusion Map - AO 
 Specular Map - SPC 
 Tangent Normal Map - NRM 
 Environment Reflection Map - ENV 
 Glow Maps - GLO 
 Bump Map - BMP 
 Displacement Map – DISP 
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Here is an example set of textures created specifically for the skylight model mentioned before.  You 
would want to emulate this name convention for your own texture files. 

 glass_skylight_bubble01_COL 
 glass_skylight_bubble01_SPC 
 glass_skylight_bubble01_AO 
 glass_skylight_bubble01_NRM 
 
While some textures are made and UV mapped to a specific model, many textures in Sirikata are tileable 
and can be used on terrain or applicable models.  Things such as grass, bricks, and concrete fall under the 
category of tileable textures.  Listed below are examples of tileable textures: 

 tree_bark01_COL – (tileable bark texture) 
 grass_short01_COL – (short grass, could be any color, if a specific color needs to be handled then) 
 grass_shortbrown01_COL – (short brown grass, probably dead or dying grass) 
 rock_cliff_kunst01_COL – (a cliff texture specifically for the Bornholm Kunst Museum project) 
 stone_path_kunst01_COL (a stone path texture specifically for the Bornholm Kunst Museum project) 
 
A general list of top-level names for textures is as follows: 
 

 Tree  Bush  Rock  Stone  Dirt 

 Grass  Road  Concrete  Roof  Tar 

 Plaster  Brick  Drywall  Wood  Pattern 

 Stucco  Blacktop  Paint  Paneling  Siding 
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Sample Folder and File Structure 
 
/sirikata/ 
            -The system, platform, engine and everything once it is imported. 
  
/sirikatacontent/documentation/ 
-Where all documentation exists for Sirikata, Pipeline, Tutorials, etc. 
 
/sirikatacontent/ 
            -Primary asset storage area for use by content designers, this resides separately and is before final 
import to Sirikata. 
 
/sirikatacontent/mesh 
 -The top directory for models.  Every model will have its own folder within the directory. 
 
/sirikatacontent/ogreexports/ 
-where all exported scenes go, the folder of the export and its accompanying files (/ash_01/ash_01.scene 
ash_01/materials etc) These folders within are ready to be dragged directly into Sirikata. 
 
/sirikatacontent/textures 
            -Finalized Textures ready for import, and to be used during material creation within Max. 
 
/sirikatacontent/textures/TYPE 
-Type deliniates the type of texture, this is purely for ease of storage use for artists as once the export is 
complete, the texture resides within its corresponding mesh folder, under materials. 
 
/sirikatacontent/texture_ref/ 
            -The massive folder utilized for working on textures, texture references, photos and all collage 
references for each project. 
 
/sirikatacontent/projects 
            -Each new folder will be the storage location  for import directly into Sirikata. (Ex. /Kunst/ for the 
Speed Limits Kunst museum project). 
 
/sirikatacontent/scripts/ 
-Future useage for scripting, maybe CVS files can reside here? 
 
/sirikatacontent/toolbox/ 
-Not to be confused by Utilities, this is where we drop photoshop brushes, config files, palet files, etc. 
 
/sirikatacontent/utilities/ 
-All utilities that we are permitted to redistribute that are required by content designers (ogre exporter, 
dds plugin, etc) 
 
 
NOTE: For group projects, make sure that the sirikatacontent folder is placed at the top level of your hard 
drive (C:) to avoid any potential file path errors when sharing content with your group.
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Modeling with Maya 

Maya Setup 
1. Open Maya and go to Window > Settings/Preferences > Preferences. 

 

 
 

2. There are several changes that need to be made.  Under the Settings category, change the 
Working Units to “meter.” 
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3. Next, under the Cameras category, change “Far Clip” to 1,000,000 and the “Near Clip” to .001.   
 

NOTE: The screenshot below shows incorrect information, but does show where and how to edit the 
Camera preferences.  Input the values listed above, not those in the screenshot. 
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Working in Maya 

Harden / Soften Normals: 
Maya default assumes that all of your edges are hard-edged surfaces when you are modeling. In some 
instances you may want to soften certain edges or make certain edges hard.  Select the edges to soften or 
harden via edge mode, then go to Normals > Soften Edge (or Harden Edge) in the polygon menu. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Creating Multiple UV sets: 
Go to Window > UV Texture Editor 
Polygons >Copy UVs to UV Set. 
 
Alternatively you can create an empty UV set, 
especially if you need to change the UVs or how 
they are laid out. 
 
NOTE: When naming the new UV set, use map1, 
map2, map3 for your UV set names. 
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Assigning Multiple Materials to same Mesh to 
Faces (for Max) 
In order to help speed up the process of working within 
3DS Max, Maya users should utilize assigning different 
materials (always phong) to faces that use a different 
material, even if they are part of the final object. A case 
example would be the Glass of a window within its 
frame. The frame has a different material from the glass. 
 
To do this in Maya, simply select the faces that will be the 
different material and either choose Assign New Material 
> Phong (or Assign Existing Material if you have already 
created a material). 
 
 
 
 
 
 
 
 
 
 
 
 
 
         

 

Object Naming (mesh names) 
It is important to maintain naming for the purposes of 
redundancy and knowing what is what. Within Maya 
open Window > Outliner and simply double click on the 
mesh and rename it accordingly. 
 
NOTE: Naming is important as the end exported FOLDER 
to Ogre must be named the mesh name, in this case 
/tree_ash01/.  (Disregard the file name in the screenshot; 
it should be tree_ash01) 
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Set Pivot Points 
There are several options depending on the workflow of your 
scene to set the pivot point. 
Primary Example: 
A single object for import into Sirikata 
 
Make sure to move the object to the center of the grid.   You can 
do this by selecting the object, hitting W for translation, and 
holding down 'X' to force the object to snap to the grid, then 
moving it to the center of the grid. 
 
This centers the object to the world space. In this example the 
tree is standing on the grid, this way when moving around in 
Sirikata the tree can be placed using its pivot on the bottom, 
where it will be across Terrain. With other models you will want 
to center the pivot first in the model, then snap the model to the 
grid in Maya's World Space. 
 
 
To Center the pivot of the model, go to Modify > Center Pivot. 
 
 
After you are completely finished with the mesh, you should 
delete the History to clear out any metadata that we don't need 
to save. Go to Edit > Delete All by Type > History. 
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Freeze Transformations 
Next is it important to freeze the transformations on the mesh. Do this when 
you are utterly completed with the mesh, and AFTER you have deleted the 
History. Go to Modify > Freeze Transformations. 
 
 
 
 
 
 
          
 
 
 

Exporting using COLLADA 
Make sure the object or objects that are finished and ready for export 
are selected, and then go to File > Export Selection…  A dialogue box will 
appear. 

 
Make sure only the following 
checkboxes are checked; 
 Default file extensions (.dae) 
 Polygon Meshes 
 Normals 
 Texture Coordinates 
 Export References 
 YFov     
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Modeling with 3ds Max 
3ds Max Setup 
 
1. Open 3ds Max 9 and go to Customize > Units Setup.  Under 

Display Unit Scale, select the “Metric” bubble and choose 
“Meters” from the dropdown menu.  Click “OK.” 

2. Go to Customize > Preferences and select the “Viewports” tab.  
Under Display Drivers, choose “Configure Driver…”  A pop-up 
called “Configure Direct3D” should appear. 

3. In the pop-up, check “Enable Anti-Aliased Lines in Wireframe 
Views” under Appearance Preferences, and “Match Bitmap Size 
as Close as Possible” under both Background Texture Size and 
Download Texture Size.  Set the sizes to their highest values, 
1024 and 512 respectively.  Click OK. 
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4. Now, go to the “Files” tab.  If you’re not very organized, you will want to turn on “Increment on 
Save,” which will save each file as 01, 02, etc.  Turn on Auto Backup and enter the settings below. 

 

   
 
BUG: The Ogre Exporter creates the file MaxStartUI.mnu whenever 3ds Max is closed.  This bug is 
documented in the Troubleshooting for Ogre Exporter section.  Until this bug is fixed, the user must delete 
MaxStartUI.mnu or 3ds Max will crash on start up. 
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Importing into 3ds Max from COLLADA 
1. Open 3ds Max 9 and go to File > Import…  Select “COLLADA (*.DAE, *.XML)” as your file type. 
2. Navigate to the folder where your COLLADA file is located and select it, then hit Open. 
3. Select the model and navigate to the Modify tab on Command Panel.  Your object should be listed as 

an “Editable Poly.”  If not, right click the object and select Convert To: > Convert to Editable Poly. 
 

 
 

4. Open the Material Browser by pressing “M” on your keyboard.  Use the eyedropper tool and select 
your mesh.  A new material should appear in the first slot in the browser.  This material is created 
when exporting a mesh from Maya with COLLADA, and it can cause massive errors.  This material HAS 
to be deleted before you can go any further. 

 
5. This is how the material browser will look right after 

you use the eyedropper.  The problem material, in 
this case, is ash01_phong-fx.  This name will change 
based upon your mesh and assigned material, but will 
ALWAYS end in “-fx.” 

6. Select a blank material slot and apply the material to 
your mesh.  To get rid of the problem material, select 
it and push the “X” button above the eyedropper 
button.  Choose the first option, “Affect mtl/map in 
both…” in order to delete the material from both your 
Material Browser AND the mesh it is applied to.  If 
you choose the other option, it will only delete it from 
the browser, but its information will still reside in the 
mesh. 

7. One problem, however, is that the material still 
retains its old name.  In order to correct this, click and 
drag an empty material slot (any will do) over the slot 
with the name ending in –fx.  Select the material slot 
of the –fx material and make sure there is no 
“COLLADA CA” dialogue box.  If this is gone, you’re 
golden. 
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Working in 3ds Max 

Smoothing Groups 
Similar to Harden/Soften Normals in Maya, 
the Smoothing Groups feature in 3ds Max 
determines whether the edge of an object is 
hard, like the edge of a table, or soft, like the 
edge of a pillow.  Select your object and click 
the drop down icon next to “Editable Poly” in 
the Modify tab.  Select “Polygon.”  Navigate to 
the “Polygon Properties” section and drop the 
menu to find “Smoothing Groups.”  Set up 
your smoothing groups accordingly, or if you 
are importing using COLLADA, make sure that 
your smoothing groups have transferred over 
correctly from the program you originally 
modeled in.  This model only has 1 smoothing 
group, because it is completely hard edged. 
 

Material IDs 
If your object needs to have more than one 
material applied to it (for example, a window: 1 
material for glass, 1 material for the wood frame).  
The Material IDs section is located right above the 
Smoothing Groups, under “Polygon Properties” 
section.  The model I am working with, tree_ash01, 
only has one material ID because it only needs one 
– the leaves and bark do not require separate 
materials because they would have the exact same 
material set up.  There isn’t a hard limit, but try and 
have less than 6 material IDs per object.  You are 
welcome to try as many as you would like on an 
object. 
 
 
 

Object Naming 
Whether you have imported your file using COLLADA or you started off 
in 3ds Max, it is important that your object maintains the name 
throughout its creation.  In order to name your mesh, go to the Modify 
panel.  The top input area is your mesh’s name.  Change it accordingly. 
 
NOTE: Naming is important as the end folder to which Ogre exports 
your mesh to must be named the same as the mesh (in this case the 
folder would be /tree_ash01/).
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Creating an Object with Multiple Materials 

When creating an object with multiple materials, you have to select the individual polygons you would 
like to apply the material to.  In the image below, I’ve selected the frame of the window that I want to 
have the wood texture applied to.  For the Material ID, go to “Set ID.”  Enter the number 1 and press 
Enter.  Select the polygons of the next material and set the ID to 2, etc.  Press M on your keyboard to 
open the Material browser and follow the steps for setting up a material. 
 

 
 
I created a material for wood 
and a material for glass and set 
up the UVs.  Go to “Select ID” 
and choose ID #1, which should 
be the frame.  These polygons 
should become outlined in red.  
Apply your wood frame 
material to Material ID #1.  
Now, select ID #2 and select the 
glass pane and apply the glass 
texture.  You now have an 
object with multiple materials, 
broken down into organized ID 
sets. 
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Map Channels and Multiple UV Sets 
For more advanced meshes and materials, multiple UV sets may be required.  Unfortunately, 3ds Max has 
trouble keeping track of multiple UV sets, or, as it refers to them, Map Channels.  If you’ve imported from 
Maya using COLLADA, you may want to go through this process just in case.  Go to the Modify tab and 
apply an “Unwrap UVW” modifier.  Create your basic UV and make sure that the Map Channel is set to 1. 
 

Now click “Save…” and save your UV 
out as map1.uvw.  Now, right click 
on the “Unwrap UVW” and select 
“Collapse All.”  Confirm and you 
should only see Editable Poly left on 
the Modify tab.  Now, apply another 
“Unwrap UVW” modifier and make 
sure you change Map Channel to 2.  
Now, choose “Load…” and select the 
.uvw file you saved out.  Edit the UV 
as you see fit.  You will be applying 
specific textures to each UV later. 

a. Map Channel #1: 0 to 1 
textures 

b. Map Channel #2: Tileable 
textures. 

c. Map Channel #3: Grunge 
maps 
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Creating .DDS Textures for 3ds Max and Sirikata 
All textures need to be converted into .dds files using the NVidia plugin prior to exporting the model from 
3D Studio Max.  The link to the plugin is provided in the Basic Requirements section. 

Texture Map Creation 
1. Start Photoshop and open your texture file. 
2. Keep master files for all textures at 2048x2048, or if possible 4096x4096.  All textures must be in 

powers of 2 (e.g., 2x2, 512x512, etc.) 
3. Before saving your file as a .dds, go to Layers > Flatten Image.  Make sure there is only one layer 

when you go to save. 
4. Go to File > Save As > and choose .D3D/.DDS 

a. For almost all texture maps save as a DTX1 
b. Have Generate MIP maps radio on for ALL TEXTURE MAPS 
c. Click Image Options and at the bottom check on Pre Modulate Color 
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Normal, Occlusion, and Alpha Channel Textures 

1. Normal Map 
a. Create your normal map using Crazybump or the NVidia Normal Map filter. 
b. Open your Channels browser by going to Windows > Channels or clicking the Channels tab. 
c. Right click the Red Channel and choose “Duplicate Channel…”  Name it “Alpha.” 
d. Hide the “Alpha” Channel and select the RGB Channel. 
e. When you Save As > .dds, be sure the Alpha box is checked. 
f. For Normal maps save as a DTX5 interpolated alpha (DO NOT use DXT5_NM) 

i. Use DTX3 explicit alpha if you don’t want any gradient on your alpha borders (either 
ON or OFF) 

 

 
 
 
2. Ambient Occlusion 

a. Create an Alpha Channel 
b. Create a B&W grayscale Alpha mask, and copy it into the Alpha Channel. 
c. When you Save As > .dds, be sure the Alpha box is checked. 
d. If your Ambient Occlusion map has an alpha in the Alpha Channel, save the file with DTX5 

compression (DO NOT use DXT5_NM). 
 

3. Alpha Channel Texture (such as foliage, glass) 
a. Prepare your texture and its Alpha Channel. 
b. Save as DXT3 or DXT5. 
c. When you Save As > .dds, be sure the Alpha box is checked. 
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Material Creation in 3ds Max 

Material Map Slots Explanation 
When creating materials, all texture files loaded need to be in .dds format.  To open the Material browser, 
press “M” on your keyboard.  Underneath Shader Basic Parameters should be the Maps section.  Drop 
down the menu to see all the available map slots.  Below are detailed descriptions about the types of 
textures you would put into which slots. 
 

Diffuse Color:  
Your Diffuse map goes here.  This Map slot has the most versatility for combining multiple Color 
Maps, Dirt Maps, separate Ambient Occlusion Maps, and so on. Detailed Material creation 
combinations are covered later. 
1. For a basic Diffuse texture, click the map slot next to Diffuse Color and choose “Bitmap.” 

 
 
Ambient Occlusion: 
1. If you have an ambient occlusion map, choose 

“RGB Multiply” instead of “Bitmap” for the 
Diffuse Color.  

2. Color #1 is always the Ambient Occlusion Map.  
In the map slot, pick “Bitmap” and choose your 
Ambient Occlusion .dds file. 

3. Color #2 can be any of the following: 
a. Your Diffuse texture, loaded as a 

Bitmap, or combined with other 
textures, such as grunge maps, through 
RGB Multiply, Composite, or Mix. 

 
 

Specular Color: 
1. Choose “Bitmap” and select your Spec Map texture. 

 
 

Self Illumination:  
Leave at 100%.  The amount of glow your material will have will be based on the texture itself, 
not the map slot percentage. Note you must also turn on Phong Basic Parameters > Self-
Illumination > Check Color and change the color picker to pure white. 
1. Choose “Bitmap” and pick your Glow Map texture. 
2. If there is no Diffuse Color Map, then embed the Alpha in this slot. 
3. Filter Color:  Check this on and it will be the HDRI Glow Map, it is Self Illumination/Filter 

Color amount.  Actual Glow amount is determined by the percent of Field of View in Sirikata. 
 
 

Opacity:  
1. Check it on, but this map is only needed to display properly in Max. 
2. If it has an Alpha, it must match the map channel of the Diffuse Texture Map in the Diffuse 

Color slot, and the Opacity slot must use the same Diffuse Texture Map. 
3. The textures won’t be loaded twice by the engine 
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Bump:  
Both the Normal Map and Bump Map go into 
this slot. Select “Normal Bump” instead of 
“Bitmap”, and enter the Normal map under the 
Normal slot.  If you have a Bump map as well, 
enter it under the Additional Bump slot. 
1. Tangent Space 
2. Extra Expensive with Dirt Channel  
 
 
Reflection: 
Enter the Environment cube Map in this slot.  Good for large interiors and reflective objects.  
There is very little cost to the engine when rendering these. 

 

Steps for Creating a Basic Material 
To create a simple material, like the one to the 
right, is quite simple once you have all your 
textures saved in .dds format and your UVs set up 
properly.  Open the Material Browser and select a 
blank, empty material.  Under Shader Basic 
Parameters, change “Blinn” to “Phong.”  Following 
the Material Map Slots Explanation guidelines, set 
up your texture maps accordingly.  Rename the 
material in a way that will make sense to whoever 
opens the document.  The sample material, to the 
right, belongs to the mesh tree_ash01.  This is a 
rather simple material.  It has all the basic materials 
your model will need to look good. 
 

Steps for Creating a Multi Sub Object Material 
Multi-Sub object materials are often used in conjunction with Material IDs.  They allow for you to group 
multiple materials under a header, allowing you to apply all the sub-materials to a mesh in one go.  One of 
the perks of this is that the sub-materials can still exist in the Material Browser in separate slots, allowing 
you to work on individual materials and simultaneously update the Multi Sub object material at the same 
time.  In the Material Browser, select a new material.  
Below the material slots, you should see a button that 
says “Standard.”  Click this and choose “Multi/Sub-
Object.”  You will now see multiple slots for materials.  
Drag materials that you have made in into the slots.  
Next to the slots you will see a space for input under 
“ID.”  This is where you will state the Material ID for each of the materials you place in your Multi Sub 
object.  So, if I were to apply this Multi Sub material to my model, which has two Material IDs, which ever 
material is in slot #1 of my Multi Sub object will be applied to the polygons with Material ID #1, etc.  If you 
have an object with multiple Material IDs and materials assigned, you can use the eyedropper to 
automatically create a Multi Sub Object material for you.  If your object has multiple UV sets that were set 
up earlier, you can tell your “Bitmaps” which Map Channel to use by entering the Map Channel number in 
the dialogue box. 
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Example of an Advanced Material 
This Multi-Sub object material shows the power of the Material Browser.  I will not provide step-by-step 
instructions explaining how to set up the material; rather, to the right is an image of the material’s tree, 
showing you each of the individual parts that has gone into making each material.  You should be able to 
look at this and reverse engineer it using your own textures. 
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Hard Rules for Material Creation 
1. Maximum Maps per Material is 10 

a. The maximum number of unique texture maps on any material is 10 
 

2. Certain Materials Are Applied to Specific UV Sets 
a. Asda 

 
3. Match the Diffuse and Specular Maps in order, Material Type, and UV Set #’s 

a. The structure of the maps for the Diffuse texture (after the AO RGB Multiply) and Spec should be 
the same. 

 
 
 
 

 
 
 
 
 
 
 
 

 
 
 

4. The AO alpha channel will always be applied to the 2nd material 
a. Except the Normal 

 
5. One Bump Map Allowed 

a. The Bump map is by far the most expensive texture map to use (only if you have more than one 
UV set) 

b. Never try to use more than one, and if a Bump doesn’t provide enough effect, do not use it at all. 
 

6. Map #2 for all materials must have matching UV Sets/Map Channel 
 

7. UV Set #2 and #3 should be upright (perpendicular) 
a. Tiling UV Set #2 should usually be upright (not rotated) and scaled to the correct Units 

(Determined by the size of your materials and the objects that are sharing those same materials).  
Most tileable textures are designed to tile in the upright position. If one makes a texture that 
runs parallel to the ground, then consult with the art team before completion. 

b. This should also keep normals aligned to the tangent space. 
 

8. Maximum of 3 UV Sets 
a. Use up to 3 Map Channels and no more. 

 
9. Alpha Channels (Making Masks) 

a. To make your Texture Map use and Alpha it must have the following radio buttons checked un 
the Bitmap Parameters dialog 

i. Mono Channel Output: Radio on for Alpha 
ii. RGB Channel Out: Radio on for Alpha as Gray 

iii. Alpha Source: Radio on for Image Alpha 
iv. Check on Premultiplied Alpha 
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b. To make a texture with an Alpha do the following: 
i. Load your texture with the alpha channel into the Opacity slot under Maps, check it 

on, and make sure it is 100 for the Amount 
ii. The texture one uses for the Opacity slot must be the same map used in the first 

Diffuse Color slot. 
iii. They must also use the same UV Set. 

c. If your Material is 1-Sided (only visible from one side), it will not count as a new Material 
d. If your Material is 2-Sided (only visible from one side), it will as a new Material. Check the Make 

2-Sided (See Fig 3) box under Shader Basic Parameters. 
 

10. Only 3 of the following Maps can be used on a given material 
a. Glow 
b. 3rd Spec 
c. 3rd Diffuse 
d. 2nd Normal 
e. Reflection 
f. Addtionally, only 2 of the following maps can be used on a given material 

i. Glow 
ii. 3rd Spec 

iii. Reflection 
 

11. Specular Color can’t have more maps than in Diffuse Color 
 

12. Cost Considerations 
a. Little Glow & AO 

Each new UV Set is another Multiple for the cost of a bump 
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Sirikata Material Types 
 
1. BASIC MATERIAL 

 
 
 
 
 
 
 

Limitations: This material cannot use Ambient Occlusion, glow, reflection, environment, or grunge maps. 
 
 
2. BASIC MATERIAL, with Normal but no Bump 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Limitations: This material cannot use Ambient Occlusion, glow, reflection, environment, or grunge maps. 
 
 
3. SINGLE DIFFUSE, Max Detail 
One Diffuse with Ambient Occlusion and Grunge and Additional Normal on UV Set 1 
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Working in 3ds Max, cont. 

Setting the Pivot Point 
Once you are COMPLETELY finished modeling, you’ll need to make sure 
the pivot point is set up properly.  The pivot point determines how your 
object is moved within Sirikata.  While it can be placed anywhere you 
choose, in order to avoid possible errors, the pivot point should always 
be placed at the base of the object.  Make sure the bottom of your object 
is touching the grid, or is extremely close.  Go to the “Hierarchy” tab, 
select “Pivot,” then “Affect Pivot Only” under Move/Rotate/Scale.  Now, 
make sure you are using the “Move Tool.”  You should see 
the Move gizmo, but it will look a little different than normal 
because you are affecting the pivot point of the object 
rather than the object itself.  Now, set the Z value (the 
height) of the pivot point, if it is not already, to 0.  The pivot point of the 
object should now be the object’s base, and on top of the grid. 

 
  



32 
 

Reset XForms 
Once you have set the pivot point, you’re ready to do the last step before exporting.  You need to reset the XForm 
of your object.  Go to the “Utilities” tab and select Reset XForm.  Make sure your object is selected and then 
choose “Reset Selected” under Reset Transform. 
 
Go to the Modify tab.  There should be a new XForm 
modifier on your object.  When you select it, there 
should be an orange selection box around your 
object.  If so, the Reset XForm worked.  Right click 
on the XForm modifier and choose “Collapse All” 
from the drop down list.  You should be left with an 
Editable Poly; if not, convert your object back to 
one. 
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Exporting from 3ds Max  
Once you have your materials set up and gone through the other required steps, you’re ready to export your 
object using the Ogre Exporter.  Select your object and go to OgreMax > Export Selected 0.1.3.  Create a new folder 
under SirikataContent/Models and name it the same name as your object (in my case, tree_ash01).  Save your 
.scene file in this new folder.  3ds Max will begin exporting.  This can take a minute or two.  If you check the folder, 
you should have a .scene file and three folders: exportlogs, materials, and models.  Now you can try importing your 
object into Sirikata using the drag and drop feature.  If it doesn’t appear, check that you have named all your files 
correctly and that all your materials were in the correct folder when you exported. 
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Installing and Running Sirikata 
Installing Sirikata 

1. For 32-bit users: Go to C:\Program Files\ and create a Sirikata folder.  Skip to step 3. 
2. For 64-bit users: Go to C:\Program Files(x86)\ and create a Sirikata folder. 
3. Go to http://www.sirikata.com/builds/ and download the latest build of Sirikata. 
4. Open the .zip file and go down one directory to get to the folder which contains sirikata.bat. 
5. Copy the contents of this folder into the Sirikata folder you created. 
6. If you have an older version of Sirikata installed already, give Windows permission to overwrite the files. 
7. Delete the file ogre.cfg. 

 

Running Sirikata 
1. You need to be on the internet to access Sirikata, so much sure you have an active internet connection. 
2. Double click sirikata.bat and let it load.  Do not close the cmd.exe, the DOS window running in the 

background. 
3. A configuration screen should appear, titled OGRE Engine Rendering Setup and choose the correct 

options. (See Fig ) 
a) Rendering Subsystem: Direct3D 9 Rendering Subsystem or OpenGL 
b) Anti-aliasing: Whatever your GPU can handle 
c) Full Screen: No 
d) Video Mode: Whatever resolution your monitor and GPU can handle 

4. Click “OK.”  The settings window will close and Sirikata will open. 
5. It can take as long as a couple of minutes for the engine to load.  Be patient. 

 

Navigating Sirikata 
Sirikata currently uses keyboard commands for all controls.  A UI will be added soon. 
 
Camera Movement 
You can navigate scenes in Sirikata in a way similar to Second Life using the arrow keys on your keyboard. 
 Up  –  move forward 
 Down  –  move backward 
 Left  –  pan left 
 Right  –  pan right 
 Page up  –  move up 
 Page down  –  move down 
 Shift + left  –  slower pan left 
 Shift + right  –  slower pan right 
 Left mouse click + drag  –  change camera angle 
 
Object Manipulation (Using left click and drag on mouse) 
 W  –  move selected object mode 

a) default behavior   –  move object in sync with mouse, i.e. on a plane parallel to the camera plane 
b) with SHIFT key down   –  move object along X axis 
c) with CTL key down   –  move object along Z axis 
d) with SHIFT+CTL key down   –  move object along Y axis (vertical) 
e) with ALT key down   –  slower, finer movement 

 E  –  rotate selected object mode 
a) default behavior   –  rotate object about Y axis (rotate in place while standing on the ground) 

http://www.sirikata.com/builds/�
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b) with SHIFT key down   –  rotate about the X or Z axis.  Which one is used depends on the orientation 
of the camera with respect to the bounding box.  This is difficult to explain but is intuitive in practice. 

c) with CTL key down   –  will rotate about the other axis. 
d) with ALT key down   –  slower, finer movement 

 R  –  scale selected object 
 G  –  group selected objects 
 Alt + G  –  ungroup 
 Enter  –  enter group (selection is quirky) 
 Esc  –  exit group 
 D  –  duplicate selected object 
 B  –  create light 
 
Scene Save/Load 
 CTRL + S  –  This will save a new file, scene_new.csv.  To load this file the next time Sirikata runs, backup your 

current scene.csv file and rename scene_new.csv as scene.csv. 
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Loading Scene Files 
1. In order to determine which scene to open, Sirikata searches for the file scene.csv in the main folder.  This 

file tells Sirikata what to load and how to load it.  Of course, in order to load a scene, you must have all 
the content files in the correct location for the scene to run.  If you are sure you have all of the textures, 
meshes, sound files, etc. downloaded, you may open that scene.csv. 

2. Backup your current scene.csv by renaming it scene_backup.csv or whatever name you like, such as 
scene_BornholmKunstMuseum.csv if you are backing up the Bornholm Kunst Museum scene. 

3. Download your new scene file from http://www.sirikata.com/builds/scenes/. 
4. Rename whichever file you download as scene.txt and drag it into the Sirikata directory. 
5. Run sirikata.bat and the new scene should load. 

 

 
  

http://www.sirikata.com/builds/scenes/�
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Importing into Sirikata 
1. Go to the directory where your Sirikata source files have been placed (normally C:\Sirikata). 
2. Make sure you have the correct scene.txt ready so that you will import your object into the correct scene 

file. 
3. Open sirikata.bat and wait for Sirikata to load. 
4. Once your scene has opened, go the folder where your Ogre file folder should be located (normally 

C:\SirikataContent) 
5. Drag the Ogre file folder into Sirikata.  I am importing the file tree_ash01, an ash tree, so I am dragging 

the entire tree_ash01 folder that the Ogre Exporter created onto my Sirikata window. 
6. Using the keyboard commands, move your object through the scene or manipulate it using scale and 

rotate. 
 

 
 

7. Once the object is set up as you like it, you can save your scene by pressing Ctrl + S.  The file will be saved 
as scene_new.txt in your Sirikata directory so that it does not over write your current scene.txt file.  Make 
sure to rename your files if you want to load the updated version next time you load Sirikata. 
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Notes 
1. Update the keyboard commands 
2. Materials section needs to be redone 
3. Map Channels and Multiple UV sets 
4. Include date in file naming for sharing 
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